Linux(Debian)下安装最新Qt5.15.2————附带详细步骤

0 背景

因为工作原因,需要用到linux下的软件,平时使用Qt都是使用Mac和Windows进行开发。原本以为安装会一帆风顺的进行,结果还是遇到了很多坑,此文就是记录这些坑的。

1 安装

  • 1,下载软件安装包,后缀为.run
    在这里插入图片描述

  • 2,cd进入安装的文件目录下,输入以下指令:

    • 授予权限,chmod 755 qt-unified-linux-x64-4.0.1-online.run
    • 执行安装,sudo ./qt-unified-linux-x64-4.0.1-online.run
  • 3,安装完毕后,进入目录,然后运行程序

    • cd /opt/Qt/Tools/QtCreator/bin

2 问题

当我进入- /opt/Qt/Tools/QtCreator/bin下时,运行编译器出现下面的错误,查阅资料就是核心库没有导入。【需要查看运行错误时,输入export QT_DEBUG_PLUGINS=1来打印详细的错误信息】
在这里插入图片描述
更具的上面的提示,发现了错误是缺少libxcb-util.so的库,最后在此链接里找到了【在这里要感谢https://www.cnblogs.com/mariocanfly/p/14061631.html这篇博文提供的下载链接】,然后使用命令进行安装sudo dpkg -i ./libxcb-util1_0.4.0-1+b1_amd64.deb,然后就可以愉快的使用Qt了。
在这里插入图片描述

3 后记

成功启动Qt Creator后,发现使用不了编译文件,经过查阅一些资料才发现,原因是没有安装gcc和g++【例如:安装g++sudo apt-get install g++】,安装后,就可以正常编译运行了。原本以为就可以愉快玩耍的我,结果一编译运行又出现了错误:-1: error: cannot find -lGL,查阅资料发现问题是缺少库,安装库后,解决了问题:

sudo apt-get install libglu1-mesa-dev

“铛”、“铛”、“铛”,出现了久违的界面,哈哈,这会是真的安装好了。
在这里插入图片描述

已标记关键词 清除标记
©️2020 CSDN 皮肤主题: 岁月 设计师:pinMode 返回首页